Mysidia Adoptables Support Forum

Mysidia Adoptables Support Forum (http://www.mysidiaadoptables.com/forum/index.php)
-   Questions and Supports (http://www.mysidiaadoptables.com/forum/forumdisplay.php?f=18)
-   -   URGENT HELP NEEDED! (http://www.mysidiaadoptables.com/forum/showthread.php?t=5557)

goofyunicorn 02-28-2018 11:55 AM

URGENT HELP NEEDED!
 
Earlier, I accidentally put a theme that wasn't compatible with Mysidia in the theme folder. I deleted it straight away. It seems to be only my account that comes up with an error when I type in the web address as people have told me it works on their account. What do I do? I can't get in to the ACP or the website, just the cPanel. I need help right now, as I promised to release 12 new adoptables today and I have had emails saying people are waiting. :ohnoes:

The error is this:
Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file 'template.tpl'' in /home/beausavi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /home/beausavi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php(374): Smarty_Internal_TemplateBase->fetch('template.tpl', NULL, NULL, NULL, true) #1 /home/beausavi/public_html/classes/class_template.php(135): Smarty_Internal_TemplateBase->display('template.tpl') #2 /home/beausavi/public_html/classes/class_view.php(280): Template->output() #3 /home/beausavi/public_html/classes/class_frontcontroller.php(102): View->render() #4 /home/beausavi/public_html/index.php(74): FrontController->render() #5 /home/beausavi/public_html/index.php(78): IndexController::main() #6 {main} thrown in /home/beausavi/public_html/inc/smarty/sysplugins/smarty_internal_templatebase.php on line 127

goofyunicorn 02-28-2018 12:09 PM

I went to line 127 and it says:

PHP Code:

throw new SmartyException("Unable to load template {$_template->source->type} '{$_template->source->name}'{$parent_resource}"); 

I have a feeling I should delete that line but I know nothing about coding :P

Dinocanid 02-28-2018 04:39 PM

Don't delete it please, that'll just cause more problems xD The problem isn't in the code at all actually, it's because deleting the theme doesn't change the database, so the site is looking for a theme that doesn't exist. Just go to phpMyAdmin, look the the user_settings table and change your theme back to "main" and it should work fine.

goofyunicorn 02-28-2018 04:53 PM

Quote:

Originally Posted by Dinocanid (Post 37011)
Don't delete it please, that'll just cause more problems xD The problem isn't in the code at all actually, it's because deleting the theme doesn't change the database, so the site is looking for a theme that doesn't exist. Just go to phpMyAdmin, look the the user_settings table and change your theme back to "main" and it should work fine.

If I am on the right page, it does say main. 😕

https://ibb.co/hzVtsc

Dinocanid 02-28-2018 05:59 PM

Whoops! It's user_options, not user_settings, sorry ^-^;

goofyunicorn 02-28-2018 06:20 PM

Quote:

Originally Posted by Dinocanid (Post 37013)
Whoops! It's user_options, not user_settings, sorry ^-^;

It still doesnt work :mii:

Dinocanid 02-28-2018 07:17 PM

It doesn't work if you change your account's theme to main? Did you also try changing it to be the same as everyone else's?
Make sure you're editing the theme in your row and not another user's row.

goofyunicorn 03-01-2018 02:31 AM

Quote:

Originally Posted by Dinocanid (Post 37015)
It doesn't work if you change your account's theme to main? Did you also try changing it to be the same as everyone else's?
Make sure you're editing the theme in your row and not another user's row.



It is my account. It was on the accident theme before and now it is on main.

Dinocanid 03-01-2018 10:25 AM

That's really weird. Did you also try "elements" and "green"?
You should also delete the accident theme from the adopts_themes table too if you haven't.

goofyunicorn 03-01-2018 02:17 PM

Quote:

Originally Posted by Dinocanid (Post 37018)
That's really weird. Did you also try "elements" and "green"?
You should also delete the accident theme from the adopts_themes table too if you haven't.

Accident theme deleted and still doesnt work.

Edit: Tried other themes but still doesnt work.


All times are GMT -5. The time now is 01:20 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.